// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(1\s{0,1}\-{0,1}((\(\d{3}\))|(\d{3}))|((\(\d{3}\))|(\d{3})))\s{0,1}\-{0,1}\d{3}\s{0,1}\-{0,1}\d{4}$").unwrap();
let string = "1 555-555-5555
1 (555) 555-5555
5555555555
555-555-5555";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}