using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=#|name=)([^\[#\]]+)";
string input = @"[name=anystring]#anystring[name=anystring]#anystring[name=anystring]#anystring[name=anystring]#anystring[name=anystring]#anystring[name=anystring]#anystring[name=anystring]#anystring[name=anystring]#anystring";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}