re = /(?<=#|name=)([^\[#\]]+)/
str = '[name=anystring]#anystring[name=anystring]#anystring[name=anystring]#anystring[name=anystring]#anystring[name=anystring]#anystring[name=anystring]#anystring[name=anystring]#anystring[name=anystring]#anystring'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end