$re = '/^([a-zA-Z0-9_]+) *= *(.+)$/m';
$str = '${config.arg}
elem=${config.arg}
step = 2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);