re = /^([a-zA-Z0-9_]+) *= *(.+)$/m
str = '${config.arg}
elem=${config.arg}
step = 2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end