# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^ *(<[^\r\n<>]*>)|(\s*<[^\r\n<>]*>\s*)(?=[^\r\n<]*$)|<\\/?color[^<>]*>/\1\2/gm;t' <<< "<color=#3D8CBF>using</color> <color=#00FFFF> aaa <Dont remove this tag> System</color>.Collections;
<color=#3D8CBF>using</color> <color=#00FFFF>System</color>.Collections.Generic;
<color=#3D8CBF>using</color> <color=#00FFFF>UnityEngine</color>;
<color=#3D8CBF>public</color> <color=#3D8CBF>class</color> ChangePosition : <color=#00FF00>MonoBehaviour</color> {
<color=#0000FF>// Update <color=#3D8CBF>is</color> called once per frame
</color>
<color=#3D8CBF>void</color> Update()
{
<color=#00FFFF>UnityEngine</color>.Profiling.Profiler.BeginSample(\"Test 1\");
Test1();
<color=#00FFFF>UnityEngine</color>.Profiling.Profiler.EndSample();
<color=#00FFFF>UnityEngine</color>.Profiling.Profiler.BeginSample(\"Test 2\");
Test2();
<color=#00FFFF>UnityEngine</color>.Profiling.Profiler.EndSample();
}
}
"