using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ *(<[^\r\n<>]*>)|(\s*<[^\r\n<>]*>\s*)(?=[^\r\n<]*$)|<\/?color[^<>]*>";
string substitution = @"\1\2";
string input = @"<color=#3D8CBF>using</color> <color=#00FFFF> aaa <Dont remove this tag> System</color>.Collections;
<color=#3D8CBF>using</color> <color=#00FFFF>System</color>.Collections.Generic;
<color=#3D8CBF>using</color> <color=#00FFFF>UnityEngine</color>;
<color=#3D8CBF>public</color> <color=#3D8CBF>class</color> ChangePosition : <color=#00FF00>MonoBehaviour</color> {
<color=#0000FF>// Update <color=#3D8CBF>is</color> called once per frame
</color>
<color=#3D8CBF>void</color> Update()
{
<color=#00FFFF>UnityEngine</color>.Profiling.Profiler.BeginSample(""Test 1"");
Test1();
<color=#00FFFF>UnityEngine</color>.Profiling.Profiler.EndSample();
<color=#00FFFF>UnityEngine</color>.Profiling.Profiler.BeginSample(""Test 2"");
Test2();
<color=#00FFFF>UnityEngine</color>.Profiling.Profiler.EndSample();
}
}
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}