const regex = /(?<=CBEAM 241699|CBEAM 241711).*?(0\.2750).*?(0\.2750)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=CBEAM 241699|CBEAM 241711).*?(0\\.2750).*?(0\\.2750)', 'gs')
const str = `CBEAM 241678 245002 240528 240628 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241697 245002 240230 240330 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241698 245002 240330 240430 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241699 245002 240430 240530 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241700 245002 240530 240630 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241708 245002 240231 240331 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241709 245002 240331 240431 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241710 245002 240431 240531 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241711 245002 240531 240631 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}