use strict;
my $str = 'CBEAM 241678 245002 240528 240628 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241697 245002 240230 240330 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241698 245002 240330 240430 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241699 245002 240430 240530 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241700 245002 240530 240630 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241708 245002 240231 240331 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241709 245002 240331 240431 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241710 245002 240431 240531 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.
CBEAM 241711 245002 240531 240631 10. 0. 10. GOO
0. 0.2750 0. 0. 0.2750 0.';
my $regex = qr/(?<=CBEAM 241699|CBEAM 241711).*?(0\.2750).*?(0\.2750)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}