const regex = /\d{0,3},?\d*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{0,3},?\\d*', 'gm')
const str = `0,5
0,1
10,5
99,5
100
,0
0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}