$re = '/\d{0,3},?\d*/m';
$str = '0,5
0,1
10,5
99,5
100
,0
0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);