using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![^#]*\b(?:abc|def|ghi)\b)[^#]*#.*";
string input = @"he is abc but # not xyz
he is good # but small
he might ghi but # not abc will
he will help but # hope for def to come
he is going for vabc but # not sure";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}