re = /^(?![^#]*\b(?:abc|def|ghi)\b)[^#]*#.*/m
str = 'he is abc but # not xyz
he is good # but small
he might ghi but # not abc will
he will help but # hope for def to come
he is going for vabc but # not sure'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end