package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S+)(?:\s+\(\S+\))`)
var str = `ACM-24-01000 (ACM/KHCTAC1), LIN-24-01000 (LIN/LINR34), CBN-01001-24 (CBN/CBNE11)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}