$re = '/((one|two|three)\s.*?)((four|five|six)\s.*?)((seven|eight|nine)\s.*)/m';
$str = 'one two three four five six seven eight nine
two three four six seven eight';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);