#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*<VirtualHost\s+[^>]*>\s*ServerName\s+(?P<ServerName>\S+)\s*DocumentRoot\s+(?P<DocumentRoot>.+?)\s*</VirtualHost>"
Local $sString = "# Virtual Hosts" & @CRLF & _
"#" & @CRLF & _
"# Required modules: mod_log_config" & @CRLF & _
"" & @CRLF & _
"# If you want to maintain multiple domains/hostnames on your" & @CRLF & _
"# machine you can setup VirtualHost containers for them. Most configurations" & @CRLF & _
"# use only name-based virtual hosts so the server doesn\'t need to worry about" & @CRLF & _
"# IP addresses. This is indicated by the asterisks in the directives below." & @CRLF & _
"#" & @CRLF & _
"# Please see the documentation at " & @CRLF & _
"# <URL:http://httpd.apache.org/docs/2.4/vhosts/>" & @CRLF & _
"# for further details before you try to setup virtual hosts." & @CRLF & _
"#" & @CRLF & _
"# You may use the command line option \'-S\' to verify your virtual host" & @CRLF & _
"# configuration." & @CRLF & _
"" & @CRLF & _
"#" & @CRLF & _
"# Use name-based virtual hosting." & @CRLF & _
"#" & @CRLF & _
"##NameVirtualHost *:80" & @CRLF & _
"#" & @CRLF & _
"# VirtualHost example:" & @CRLF & _
"# Almost any Apache directive may go into a VirtualHost container." & @CRLF & _
"# The first VirtualHost section is used for all requests that do not" & @CRLF & _
"# match a ##ServerName or ##ServerAlias in any <VirtualHost> block." & @CRLF & _
"#" & @CRLF & _
"##<VirtualHost *:80>" & @CRLF & _
" ##ServerAdmin webmaster@dummy-host.example.com" & @CRLF & _
" ##DocumentRoot "D:/xampp/htdocs/dummy-host.example.com"" & @CRLF & _
" ##ServerName dummy-host.example.com" & @CRLF & _
" ##ServerAlias www.dummy-host.example.com" & @CRLF & _
" ##ErrorLog "logs/dummy-host.example.com-error.log"" & @CRLF & _
" ##CustomLog "logs/dummy-host.example.com-access.log" common" & @CRLF & _
"##</VirtualHost>" & @CRLF & _
"" & @CRLF & _
"##<VirtualHost *:80>" & @CRLF & _
" ##ServerAdmin webmaster@dummy-host2.example.com" & @CRLF & _
" ##DocumentRoot "D:/xampp/htdocs/dummy-host2.example.com"" & @CRLF & _
" ##ServerName dummy-host2.example.com" & @CRLF & _
" ##ErrorLog "logs/dummy-host2.example.com-error.log"" & @CRLF & _
" ##CustomLog "logs/dummy-host2.example.com-access.log" common" & @CRLF & _
"##</VirtualHost>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"##<VirtualHost *:8080>" & @CRLF & _
" ##ServerName CI1" & @CRLF & _
" ##DocumentRoot D:\xampp\htdocs\codeigniter_1\public" & @CRLF & _
"##</VirtualHost>" & @CRLF & _
"" & @CRLF & _
"<VirtualHost *:8080>" & @CRLF & _
" ServerName CI2" & @CRLF & _
" DocumentRoot D:\xampp\htdocs\codeigniter_2\public" & @CRLF & _
"</VirtualHost>" & @CRLF & _
"" & @CRLF & _
"<VirtualHost *:8080>" & @CRLF & _
" ServerName CI3" & @CRLF & _
" DocumentRoot D:\xampp\htdocs\codeigniter_3\public" & @CRLF & _
"</VirtualHost>" & @CRLF & _
"<VirtualHost *:8080>" & @CRLF & _
" ServerName CI3" & @CRLF & _
" DocumentRoot D:\Embedded Spaces and spaces at end of line\htdocs\codeigniter_3\public " & @CRLF & _
"</VirtualHost>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")