#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)'([^']*)'"
Local $sString = "unit Language.EN;" & @CRLF & _
"" & @CRLF & _
"interface" & @CRLF & _
"" & @CRLF & _
"uses" & @CRLF & _
" Winapi.Windows, System.SysUtils;" & @CRLF & _
"" & @CRLF & _
"type" & @CRLF & _
" TDummyParent = record" & @CRLF & _
" private const" & @CRLF & _
" Languages: array [0 .. 2] of string = ('German', 'English');" & @CRLF & _
" public" & @CRLF & _
" class var a, b, c, d: string;" & @CRLF & _
" class procedure DummyProcedure; static;" & @CRLF & _
" end;" & @CRLF & _
"" & @CRLF & _
"implementation" & @CRLF & _
"" & @CRLF & _
"class procedure TDummyParent.DummyProcedure;" & @CRLF & _
"begin" & @CRLF & _
" a := 'string-a';" & @CRLF & _
" b := 'string-b';" & @CRLF & _
"" & @CRLF & _
" c := sLineBreak + 'string-d';" & @CRLF & _
"" & @CRLF & _
" d :=" & @CRLF & _
" '1 2 3 ' +" & @CRLF & _
" '4 5 6 ' +" & @CRLF & _
" '7 8 9';" & @CRLF & _
"end; "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")