const regex = /'([^']*)'/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'([^\']*)\'', 'gm')
const str = `unit Language.EN;
interface
uses
Winapi.Windows, System.SysUtils;
type
TDummyParent = record
private const
Languages: array [0 .. 2] of string = ('German', 'English');
public
class var a, b, c, d: string;
class procedure DummyProcedure; static;
end;
implementation
class procedure TDummyParent.DummyProcedure;
begin
a := 'string-a';
b := 'string-b';
c := sLineBreak + 'string-d';
d :=
'1 2 3 ' +
'4 5 6 ' +
'7 8 9';
end; `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}