package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{3}-\d{2}-\d{4}`)
var str = `123-45-6789
123-12-1234
123
213-23-
-
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}