$re = '`\d{3}-\d{2}-\d{4}`m';
$str = '123-45-6789
123-12-1234
123
213-23-
-
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);