import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z]+-\\d+),(.*(?:\\n(?![A-Z]+-\\d+,).*)*)";
final String string = "ABC-1,01/01/1974,X1,Y1,Z1,\"RANDOM SINLGE LINE TEXT 1\",\n"
+ "ABC-2,01/01/1974,X2,Y2,Z2,\"THIS IS\n"
+ "A RANDOM\n\n"
+ "MULTI LINE\n"
+ "TEXT 2\",\n"
+ "ABC-3,01/01/1974,X3,Y3,Z3,\"THIS IS\n\n"
+ "ANOTHER RANDOM\n"
+ "MULTI LINE TEXT\",";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}