re = /^([A-Z]+-\d+),(.*(?:\n(?![A-Z]+-\d+,).*)*)/m
str = 'ABC-1,01/01/1974,X1,Y1,Z1,"RANDOM SINLGE LINE TEXT 1",
ABC-2,01/01/1974,X2,Y2,Z2,"THIS IS
A RANDOM
MULTI LINE
TEXT 2",
ABC-3,01/01/1974,X3,Y3,Z3,"THIS IS
ANOTHER RANDOM
MULTI LINE TEXT",'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end