package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[7-9]\d{9}$`)
var str = `7888909834
1234566899`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}