$re = '/^[7-9]\d{9}$/m';
$str = '7888909834
1234566899';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);