import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w* \\w*)(?<!no other) bag";
final String string = "light red bags contain 1 bright white bag, 2 muted yellow bags.\n"
+ "dark orange bags contain 3 bright white bags, 4 muted yellow bags.\n"
+ "bright white bags contain 1 shiny gold bag.\n"
+ "muted yellow bags contain 2 shiny gold bags, 9 faded blue bags.\n"
+ "shiny gold bags contain 1 dark olive bag, 2 vibrant plum bags.\n"
+ "dark olive bags contain 3 faded blue bags, 4 dotted black bags.\n"
+ "vibrant plum bags contain 5 faded blue bags, 6 dotted black bags.\n"
+ "faded blue bags contain no other bags.\n"
+ "dotted black bags contain no other bags.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}