import re
regex = re.compile(r"(\w* \w*)(?<!no other) bag", flags=re.MULTILINE)
test_str = ("light red bags contain 1 bright white bag, 2 muted yellow bags.\n"
"dark orange bags contain 3 bright white bags, 4 muted yellow bags.\n"
"bright white bags contain 1 shiny gold bag.\n"
"muted yellow bags contain 2 shiny gold bags, 9 faded blue bags.\n"
"shiny gold bags contain 1 dark olive bag, 2 vibrant plum bags.\n"
"dark olive bags contain 3 faded blue bags, 4 dotted black bags.\n"
"vibrant plum bags contain 5 faded blue bags, 6 dotted black bags.\n"
"faded blue bags contain no other bags.\n"
"dotted black bags contain no other bags.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")