# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([pP]laza)\s?([A-Za-z ]{0,})\,?\s?(\d{0,}|s\/n)\,?\s?\d{0,}[ºª]?\s?[a-zA-Z]?$"
test_str = ("calle prueba, 2\n"
"calle de la prueba, 5\n"
"Avenida de la prueba, 5\n"
"Plaza de la prueba, 5\n"
"Plaza Higuereta, 4, 7º B\n"
"Plaza Escritor Conde Zamora s/n\n"
"Avenida Ciudad de Aranjuez 18\n"
"Plaza Pintor Sorolla 125 4ºG\n"
"Polígono Industrial Aranguren 6\n"
"Plaza Gremi Passamaners 24 2º\n"
"Avenida Manuel Rodriguez Ayuso, 170\n"
"Plaza Illa de Buda 55\n"
"Plaza Walia, 21\n"
"C/Alfonso Pesquera, 6")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.