import Foundation
let pattern = #"^([pP]laza)\s?([A-Za-z ]{0,})\,?\s?(\d{0,}|s\/n)\,?\s?\d{0,}[ºª]?\s?[a-zA-Z]?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
calle prueba, 2
calle de la prueba, 5
Avenida de la prueba, 5
Plaza de la prueba, 5
Plaza Higuereta, 4, 7º B
Plaza Escritor Conde Zamora s/n
Avenida Ciudad de Aranjuez 18
Plaza Pintor Sorolla 125 4ºG
Polígono Industrial Aranguren 6
Plaza Gremi Passamaners 24 2º
Avenida Manuel Rodriguez Ayuso, 170
Plaza Illa de Buda 55
Plaza Walia, 21
C/Alfonso Pesquera, 6
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)