package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z]+(?:_+[a-z]+)*$`)
var str = `abc_____as
___dss
dsad___
wqeq_weq_wq`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}