$re = '/^[a-z]+(?:_+[a-z]+)*$/m';
$str = 'abc_____as
___dss
dsad___
wqeq_weq_wq';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);