import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:\\D*.\\D*){10,15}$)\\+?\\d{1,4}?[-.\\x20]?\\(?\\d{1,3}?\\)?[-.\\x20]?\\d{1,4}[-.\\x20]?\\d{1,4}[-.\\x20]?\\d{1,9}$";
final String string = "+49 172 7470791\n"
+ "+49 621 60-6641516\n"
+ "+49 621 60-41516\n"
+ "8-1-6641516\n"
+ "61 41516\n"
+ "6641516\n"
+ "41516\n"
+ "+1 (418) 827-5338\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}