use strict;
my $str = '+49 172 7470791
+49 621 60-6641516
+49 621 60-41516
8-1-6641516
61 41516
6641516
41516
+1 (418) 827-5338
';
my $regex = qr/^(?=(?:\D*.\D*){10,15}$)\+?\d{1,4}?[-.\x20]?\(?\d{1,3}?\)?[-.\x20]?\d{1,4}[-.\x20]?\d{1,4}[-.\x20]?\d{1,9}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}