#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?<!\\)(?:\\\\)*)%.*"
Local $sString = "\usepackage{test}%COMMENT1" & @CRLF & _
"" & @CRLF & _
"TEXT" & @CRLF & _
"%COMMENT2" & @CRLF & _
"TEXT" & @CRLF & _
"" & @CRLF & _
"Value is 10\%, this should not be removed. %COMMENT3" & @CRLF & _
"" & @CRLF & _
"begin{tikz}[" & @CRLF & _
"important 1," & @CRLF & _
"%COMMENT4" & @CRLF & _
"important 2, %COMMENT5" & @CRLF & _
"]" & @CRLF & _
"" & @CRLF & _
"TEXT" & @CRLF & _
"%COMMENT 6" & @CRLF & _
"" & @CRLF & _
"TEXT" & @CRLF & _
"" & @CRLF & _
"Table: value1&value2\\%COMMENT7" & @CRLF & _
"Table: value1&value2\\ %COMMENT8" & @CRLF & _
"Table: value1&value2 \\%COMMENT 9" & @CRLF & _
"Table: value1&value2\\% COMMENT 10" & @CRLF & _
"Table: value1&value2\\\\%COMMENT11 "
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)