using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"B-\d{3} .*";
string input = @"B-018 MyName";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}