package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`B-\d{3} .*`)
var str = `B-018 MyName`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}