use strict;
my $str = 'ABEH A501; BIOL L340; BIOL Z620; Q799; ABEH A501';
my $regex = qr/[a-zA-Z]{4}\s{1,8}[a-zA-Z]\d{3}(*SKIP)(*F)|\w+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";