$re = '/[a-zA-Z]{4}\s{1,8}[a-zA-Z]\d{3}(*SKIP)(*F)|\w+/';
$str = 'ABEH A501; BIOL L340; BIOL Z620; Q799; ABEH A501';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;