$re = '/ULong[\s]GenerateHashValue[\s]*\((?!void)[\s\w&*]+\)/m';
$str = ' inline ULong GenerateHashValue (v2oid) const;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);