re = /ULong[\s]GenerateHashValue[\s]*\((?!void)[\s\w&*]+\)/m
str = ' inline ULong GenerateHashValue (v2oid) const;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end