using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Workspace(?s)(.*)\/Output\/(?s)(.*)\/Temporary";
string input = @"Workspace/<any number of sub folders here>/Output/<computername>/Temporary";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}