package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Workspace(?s)(.*)\/Output\/(?s)(.*)\/Temporary`)
var str = `Workspace/<any number of sub folders here>/Output/<computername>/Temporary`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}