using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[;,] ?| ";
string input = @"3.14; 42.2
3.14;42.2
3.14, 42.2
3.14,42.2
3.14 42.2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}