package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[;,] ?| `)
var str = `3.14; 42.2
3.14;42.2
3.14, 42.2
3.14,42.2
3.14 42.2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}