package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b\w`)
var str = `Например имеет "Hello World". Как сделать сокращение до "HW"?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}