$re = '/\b\w/u';
$str = 'Например имеет "Hello World". Как сделать сокращение до "HW"?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);