$re = '/([abc])\1/m';
$str = 'abccbaacacb aob a2b a42c A87d bb';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;