import re
regex = re.compile(r"([abc])\1", flags=re.MULTILINE)
test_str = "abccbaacacb aob a2b a42c A87d bb"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)