using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"South African Society(*SKIP)(*F)|African";
string input = @"South African Society
South African
African Society
South African Society and African Society";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}