package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)South African Society(*SKIP)(*F)|African`)
var str = `South African Society
South African
African Society
South African Society and African Society`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}