package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Z][a-zA-Z]*\b`)
var str = `Abc,ABC?AbC,Abc123, Abc_345, abc.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}